Adonis Persona can not be used in AdonisJs 4.1.0?


#1

Why Adonis Persona says Make sure @adonisjs/framework version is >= 5.0.6 whereas AdonisJs version 5 is not born yet?

I wonder if I can still use it for AdonisJs 4.1.0 ?


#2

I’m using it with 4.1. So yes, you can use it!


#3

Hey @begueradj! :wave:

The package @adonisjs/framework is one package of many that power AdonisJs.
Since we are following semver, you could be using @adonisjs/framework 76 and still be on Adonis 4.1.

We know this is confusing, this is why there’s an RFC that will be used to communicate AdonisJs version more efficiently.