Adonis serve --dev command is instantly stopped after running in ubuntu 18.04

Recently I have upgraded my ubuntu version from 16.04 to 18.04.
The same project in adonis 4.1 was running in 16.04, When I run the command:
adonis serve --dev in 18.04 the command not persist and is like the terminal cancel without showing any error.

1 Like

You mean to install adonis ? I run command adonis -V and it show
4.1.0

1 Like

Make sure .env is fine.
Try deleting node modules and run npm install

Hopefully this will solve

The application was running fine in ubuntu 16.04. I just have upgraded the OS to 18.04, other than no changes done in the application.

Something might messed up.

Try deleting node modules and run npm install.

If the issue persists , try running node server.js to check whether app is working or not. If it works, Uninstall Adonis cli and install it back

1 Like

The app is working fine, when run the these commands npm start or node server.js . Let me try to re-install Adonis cli

2 Likes

have the same issue in one server, helps only adonis serve --dev --watch=app