Error # listen EADDRINUSE 127.0.0.1:3333


#1

In first install i see this error. Can you help what can i do with that? Thanks :slight_smile:


#2

Yeah the port is used by some other app. Error speaks for itself


#3

Hi, i’m having this same issue and it is caused bay adonis itself, cause adonis starts and when it try to reload cause some code was changed, it crash in EADDRINUSE, so it is not caused by another app using the port like @virk said, not in my case. I tried other ports and the same error occurs, it is like adonis is not reloading correctly for some reason. I opened an issue in adonis github and i’m waiting some help there too. Bellow is the issue:


#4

Hi, for now i solve this using nodemon, i’m not using the ‘adonis serve --dev’ anymore, with nodemon the problem stops.


#5

This is funny because adonis serve command use nodemon behind the scene.

I’ll dig to see where the problem is.


#6

Experience the same problem when start to use Logger in file. I suppose it’s related with adonis watching for log file and try to reboot itself somehow, or something like that. Because problem begins only when I start use file logs…


#7

$ lsof -i :3333 - will give all the list of processes that are using the port.

You can also run the server with a different port by editing PORT value in .env file