V5 API Token Problems

Has anyone successfully used api token auth guard for V5?

The related package (authentication) is not available yet for use on AdonisJs version 5.

API token auth was just released :yum:

Yesh. Do you have some problem with it?

1 Like

Yes, I do. During set up, each time I select api_token as auth guard and hit enter,
it shows ‘No items were selected’. This is really getting on my nerves right now

Can you share versions of your deps?
Just tried to initialize new project again and it works fine

I select api_token as auth guard and hit enter,
You need to hover over api_token with arrow keys and hit space to select it

Thank you for the info @McSneaky

Here is the snapshot of my dependencies. What am I getting wrong? And by the way, thanks for your responses
deps

Fianlly!!! What a relieve, followed your guidance and it worked like charm, ‘hit space bar to select and hit enter key’. Though it kinda strange because I could select other options (like lucid instead of database) just by hitting enter alone. Thanks all the same.

It’s like that because everything else is single select, but that is multi select

There were some proposals in Discord already how to improve it, so it will get better DX / UX soon hopefully :slight_smile:

Nice that you got it solved tho!

That would be very helpful. You guys are doing great